Deps issue: (Mix) Hex dependency resolution failed, relax the version requirements or unlock dependencies

(Mix) Hex dependency resolution failed, relax the version requirements or unlock dependencies

I have faced the issue when you add new dependancy to your Elixir project and appeared it used different version of some deps (because developer fixed deps version).

I added nadia Telegram API Wrapper bleeding edge version from github (not good imho, but they had new cool code in the master) and I got this error message:

The hotfix for this issue is adding explicitly poison dependancy like this:

this means it takes max version of the poison and use over all the versions.